[Bioperl-guts-l] [Bug 3041] BioPerl breaks listing of updateable modules in a CPAN shell

bugzilla-daemon at portal.open-bio.org bugzilla-daemon at portal.open-bio.org
Mon Apr 5 11:21:00 EDT 2010


http://bugzilla.open-bio.org/show_bug.cgi?id=3041





------- Comment #3 from cjfields at bioperl.org  2010-04-05 11:20 EST -------
(In reply to comment #2)
> (In reply to comment #1)
> > Fernan, this doesn't seem to be very widespread (it's the first time I've heard
> > of it since the 1.6.1 release, and it wasn't one of the fail reasons on CPAN
> > Testers).  
> 
> This is happening since ~ 1.5.x. Though I always thought someone would notice
> and fix it :) 

Nope, never noticed it.  It's the first time I recall it being reported.

> Seems like CPAN-shell is looking inside modules for version information, maybe
> comparing what's installed to what's available, and failing ... apparently this
> is only done at this stage (looking for out of date modules) so it's not
> preventing installation of the Distribution.
> 
> 
> > We will need to know the (perl version|CPAN version|OS) to try reproducing
> > this.
> 
> CPAN 1.9402 (ANDK/CPAN-1.9402.tar.gz)
> perl 5.10.0
> Ubuntu Linux 9.10

Okay, I'll check it out.  I will be installing a local perl 5.10.1 and perl
5.12 on my Ubuntu box for testing later this week, I can probably try
replicating this there.


-- 
Configure bugmail: http://bugzilla.open-bio.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.


More information about the Bioperl-guts-l mailing list