[Bioperl-l] firewalls, and DB::GenBank, is this actually solved?

Ewan Birney birney@ebi.ac.uk
Thu, 17 Aug 2000 01:00:21 +0100 (BST)

On Wed, 16 Aug 2000, Mike Cariaso wrote:

> A coworker is having a problem using Bio::DB::GenBank. Since the error message
> is 'No route to host', the firewall is immediately suspect. He now has the
> http_proxy set correctly but the problem persists. When I look at the code this
> particular module uses a socket connection, instead of the LWP UserAgent. Am I
> correct in assuming that this module does not recognize the http_proxy
> environment variable, and that therefore bug 815 is in fact not fixed?

We orginally decided not to make DB::GenBank use the LWP system, but now
this is so common it is probably worth converting it.

patches welcome ;)

>  http://bio.perl.org/bioperl-bugs/Fixed-Bugs?id=815;expression=fire;user=guest
> --
> mike cariaso      ------------------------     mcariaso@genelogic.com
> ph:510-981-3156 ------------------------------------ fax:510-649-3449
> --- Standard Disclaimer ---
> The information contained in this email message is intended only for the
> personal and confidential use of the recipient(s) named above.  This
> message may be privileged and confidential and protected from
> disclosure.  If the reader of this message is not the intended recipient
> or an agent responsible for delivering it to the intended recipient, you
> are hereby notified that you have received this document in error and
> that any review, dissemination, distribution, or copying of this message
> is strictly prohibited.  If you have received this communication in
> error, please notify us immediately by email, and delete the original
> message.
> _______________________________________________
> Bioperl-l mailing list
> Bioperl-l@bioperl.org
> http://bioperl.org/mailman/listinfo/bioperl-l

Ewan Birney. Mobile: +44 (0)7970 151230, Work: +44 1223 494420