[Bioperl-l] 0.7 aims: perl 5.0004

Hilmar Lapp hlapp@gmx.net
Tue, 14 Nov 2000 09:17:15 -0800

Ewan Birney wrote:
> I would like to put a strong claim that we should remain perl 5.0004
> compatible. I don't think this should be too hard.
> I am volunteering elia and myself on checking perl 5.0004 compatibility

Good. In general, I don't think either that it's hard; the only issue I
see is that someone has to commit himself and regularly check the test
suite on a machine with 5.004 installed after significant code changes.
I for instance can't check myself if I make changes, and a couple of
other developers may be in the same situation. The other option is to
require developers to have 5.004 installed (at least in addition) so
that they can check themselves. Obviously I wouldn't be that happy with
this option.

So, what do you think? Will you and Elia regularly check on a 5.004

Hilmar Lapp                                email: hlapp@gmx.net
GNF, San Diego, Ca. 92122                  phone: +1 858 812 1757