[Bioperl-l] GFF method in Bio::SeqFeatureI
Fri, 16 Feb 2001 13:50:35 -0600 (CST)
On Fri, 16 Feb 2001, Hilmar Lapp wrote:
> There now two methods in SeqFeatureI for every gff-concerned
> operation: gff_string() and gff2_string(), _from_gff_string(),
> _from_gff2_string(), and two named parameters in new().
> Inheriting classes all use gff_string() and friend.
> I suggest we remove the old implementation of gff_string() and
> rename Mark W.'s gff2_string() to the former. Likewise for the
> other methods.
> Alternatively, we rename gff_string() to gff1_string(), and
> gff2_string() to gff_string().
> I prefer the first option. Any objections?
Sounds good to me! (no bias here).
Plant Biotechnology Institute
National Research Council of Canada