[Bioperl-l] Test.pm does not ship with 5.004 patch level 4

Ewan Birney birney@ebi.ac.uk
Wed, 24 Jan 2001 17:26:39 +0000 (GMT)

On Wed, 24 Jan 2001, Jason Stajich wrote:

> I was hoping no one would notice... ;) 
> I found this out last week then I tried to install Test.pm on a 5.00404
> system and it won't install requires at least 5.00504.  This means our
> test suite doesn't work under 5.00404. That is not good...
> grrrr... not wanting to back port all the Test.pm dependacies... Do we
> have to roll our own replacement and have that be included?


this is a potential SHOW STOPPER. time to think about this...

We have to either 

  (a) jettison 5.00404 compatibility OR

  (b) back-port test suite (sorry jason) OR

  (c) roll own replacement

I don't like any of these. Comments?

(PS - I am not a big, huge, boy this is really making my life easier fan
of Test.pm --- what is wrong with print "ok 2\n";. I don't need a module
for this!)

Ewan Birney. Mobile: +44 (0)7970 151230, Work: +44 1223 494420