[Bioperl-l] Problems with installing bioperl using PPM3

Chris Fields cjfields at uiuc.edu
Wed Apr 7 17:22:55 EDT 2004

Everything works when using ActiveState Perl 5.8.3 Build 809, which comes 
with PPM3 as the default package manager.  It may be due to the earlier PPM 
version.  I checked the ActiveState web site documentation for ActivePerl 
5.6.1 build 635 (the newest version of the 5.6.1 branch) and there is a bug 
fix listed for PPM3.

The following link describes a problem very like yours and is from the PPM 
bug database (http://bugs.activestate.com/show_bug.cgi?id=19749&submit=Go) 
and is likely the bug that is fixed in 5.6.1 build 635, so you might want 
to upgrade to that version or to the newest 5.8.3 release for the fix.


At 02:08 PM 4/7/2004, omid at rogers.com wrote:
>Hello all,
>I have ActiveState perl 5.6.1 BUILD 633 installed on a local machine 
>running windows 2000 and I do the following:
>I type "ppm3" at the command prompt
>then type "search bioperl" (the repository is set to 
>a listing is displayed with numbers and when I attemp to issue the command 
>"describe 20" or describe "package name" I get an error saying:
>Can't call method "name" without a package or object reference at 
>E:\Perl\bin/ppm3-bin line 4265, <$__ANONIO__> line 9.
>I don't know what it means. I searched the bioperl site and looked at 
>various installation documents but nothing seems to address this type of 
>Any help you are able to provide is greatly appreciated.
>Bioperl-l mailing list
>Bioperl-l at portal.open-bio.org


Chris Fields - Postdoctoral Researcher
Lab of Dr. Robert Switzer


University of Illinois at Urbana-Champaign
Dept. of Biochemistry - 323 RAL
600 S. Mathews Ave.
Urbana, IL 61801

Phone : (217) 333-7098
Fax : (217) 244-5858 

More information about the Bioperl-l mailing list