[Bioperl-l] Installing bioperl-ext-1.4

Aaron J. Mackey amackey at pcbi.upenn.edu
Mon Dec 13 11:39:53 EST 2004

On Dec 12, 2004, at 11:13 PM, bcur001 at ec.auckland.ac.nz wrote:

> I am wanting to run code to do smith-waterman alignment. From what I 
> can see, I
> need the EMBOSS suite, which appears to come as part of 
> bioperl-ext-1.4.

Where does that appear?  EMBOSS is a separate suite of utilities, and 
does not come with bioperl-ext

> Upon attempting to run `perl Makefile.PL` from the bioperl-ext-1.4/ 
> directory, I get
> the following:
> Writing Makefile for Bio::Ext::Align
> Found Staden io_lib "libread" in /usr/local/lib ...
> Automatically using the Read.h found in /usr/local/include/io_lib ...
> Writing Makefile for Bio::SeqIO::staden::read
> Writing Makefile for Bio
> One or more DATA sections were not processed by Inline.
> And there it ends.

As it is supposed to; you've made the necessary Makefiles, all that 
remains is for you to type "make", "make test" and "make install" when 
satisfied.  The Inline warning should be ignored.

But I think what you want is to install EMBOSS, and then bioperl-run to 
get Bio::Tools::Emboss functionality.


Aaron J. Mackey, Ph.D.
Dept. of Biology, Goddard 212
University of Pennsylvania       email:  amackey at pcbi.upenn.edu
415 S. University Avenue         office: 215-898-1205
Philadelphia, PA  19104-6017     fax:    215-746-6697

More information about the Bioperl-l mailing list