[Bioperl-l] nmake test on windows

Nathan Haigh nathanhaigh at ukonline.co.uk
Sat Dec 18 08:40:38 EST 2004

Until recently I had thought that "nmake test" on windows only died with a "line too long" error if an old version of
ExtUtils::MakeMaker was being used - I thought this error had been dealt with in versions >=6.06. However, it had not! In fact using
nmake 1.5 to do "nmake test" resulted in the "line too long" error; whereas nmake 6.0 did not produce this error and conducted the
tests correctly. Since most windows users probably use nmake 1.5 I informed the writers of ExtUtils::MakeMaker to this problem and
they have come up with a fix that enables the tests to run with both version of nmake, and is currently implemented in
ExtUtils::MakeMaker dev release 6.25_01 available from CPAN.


Therefore, if you are a windows user and get the "line too long" error when trying to run "nmake test", you should install
ExtUtils::MakeMaker v6.25_01 to rectify the problem and/or used nmake 6.0.



avast! Antivirus: Outbound message clean.
Virus Database (VPS): 0451-2, 17/12/2004
Tested on: 18/12/2004 13:40:15
avast! is copyright (c) 2000-2003 ALWIL Software.

More information about the Bioperl-l mailing list