[Bioperl-l] MSG: acc does not exist, but acc is OK and bioperl version is 1.2.2

Vince Forgetta vince.forgetta at staff.mcgill.ca
Fri Feb 20 10:40:48 EST 2004

I had originally put $accession without single quotes and got the same 
error. I tried the single quotes as a debugging step. I still have the 
same problem when I remove them.

The problem seems to be sporadic. some days I can get accessions and 
other days I run into problems. Could this be the problem:



Andreas Kahari wrote:

>On Fri, Feb 20, 2004 at 10:14:40AM -0500, Vince Forgetta wrote:
>>------------- EXCEPTION  -------------
>>MSG: acc does not exist
>>STACK Bio::DB::WebDBSeqI::get_Seq_by_acc 
>>My code is:
>>   use Bio::DB::RefSeq;
>>   $gb = new Bio::DB::RefSeq;
>>   my $seq;
>>   $seq = $gb->get_Seq_by_acc('$accession');
>Perl does not interpolate variables in within single quotes.
>You probably want to say
>    $seq = $gb->get_Seq_by_acc($accession);

Vincenzo Forgetta

 Computational Biology
  McGill University and Genome Quebec Innovation Centre
  740 Dr. Penfield Avenue Room 7211
  Montreal, Quebec Canada, H3A 1A4

  Tel: 514-398-3311 00476 
  Email: vince.forgetta at staff.mcgill.ca

More information about the Bioperl-l mailing list