[Bioperl-l] Running Clustalw using BioPerl Via cgi script

Nathan Haigh nathanhaigh at ukonline.co.uk
Tue Jan 13 17:02:20 EST 2004

Here is what I'm trying to do:

1) Add NJ tree and bootstrap support to my local copy of

2) Use this module in a web (cgi) environment, to produce bootstrap trees
from sequences selected by checkboxes

3) Somehow generate trees in graphical format from the newick format trees
generated from step 2).

Progress on these steps so far:
1) Pretty much sorted a working version of the tree options for clustalw,
but still need to do some testing

2) I worked out that I needed to set the environmental variable to
clustalw (WindowsXP version on my test environment). Successfully able to
run and alignment from a fasta input file and NJ/bootstrap trees from an
alignment file.

3) Not much yet!

Which steps I need help on!
1) No help as yet

2) I would like to be able to use sequence and alignment objects instead
of specifying input fasta or alignment files to generate the alignments
and trees. I have created an array of Bio::Seq objects by using the
my $seqobj = Bio::Seq->new('-display_id' => $new_local_id,
			        '-seq' => $seq);
push @seq_array, $seqobj;

I then pass a reference to this array to run the alignment
my $aln = $factory->align($seq_array_ref);

the returned value is a simplealign object, how do I access the aligned
sequences  as I can't seem to be able to figure out how to do that! Or,
should the clustalw.pm handle simplealign objects as input? Essentially, I
need to know how to handle the simplealign object ($aln) as returned from:
my $aln = $factory->align($seq_array_ref);

I must be missing something, as I spent all day today, trying to figure
out if I'd changed something in the module itself or I'm missing something

3) I'll make these issues known at a later point, on a different thread.

Thanks for any help

-----Original Message-----
From: Jason Stajich [mailto:jason at cgt.duhs.duke.edu]
Sent: 13 January 2004 15:36
To: Nathan Haigh
Cc: bioperl-l at portal.open-bio.org
Subject: Re: [Bioperl-l] Running Clustalw using BioPerl Via cgi script

You need to provide some more error messages - it most likely has to do
with permissions as the web server (and hence the cgi) run under a
different user than the uid that when you run the script by cmd line.

What error messages do you see in your webserver log?  That will help
someone answer the question better.


On Mon, 12 Jan 2004, Nathan Haigh wrote:

> I am trying to write a cgi script that will run clustalw on an array of
> seq objects and return an alignment object. I can write a successful
> script but if I try to execute it via a browser, it fails.
> Does anyone have any experience with implementing clustalw within a
> browser setting?
> Thanks
> Nathan

Jason Stajich
Duke University
jason at cgt.mc.duke.edu
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 3095 bytes
Desc: not available
Url : http://portal.open-bio.org/pipermail/bioperl-l/attachments/20040113/179bbdd3/smime.bin

More information about the Bioperl-l mailing list