[Bioperl-l] Questions from a Bioperl beginner?

jsun at biologicaltargets.com jsun at biologicaltargets.com
Fri Jul 9 15:36:56 EDT 2004

Dear Sir or Madam;
  I tried to run some small bioperl program after I successfully installed
Perl and Bioperl in my computer. While I get some problems and need to
ask for your kind help. I run a pl file as attached below which I copied
from bptutorial file:
use Bio::Perl;
use strict;
use warnings;

my $seq_object = get_sequence('swissprot',"ROA1_HUMAN");

  # uses the default database - nr in this case
my $blast_result = blast_sequence($seq_object);


Since I didn't make any changes to the source code, it should run fine but
it failed on my computer. And the error message is:

Submitted Blast for [ROA1_HUMAN]

<hr><front color="red">ERROR: Results for RID
1089388321-32330-213160811820 not found</font><hr>

So what's the problem here? and I also tried the
Bio::Tools::Run::RemoteBlast function, it shows the same error. How can I
solve this problem? And is there any troubleshooting documents
that I can use if I get any further problem during my testing?

Your help are the most appreciated.
Thanks a lot
Jian Sun

More information about the Bioperl-l mailing list