[Bioperl-l] SeqFeatureCollection issue

Wiepert, Mathieu Wiepert.Mathieu at mayo.edu
Wed Jul 14 15:41:41 EDT 2004



I was trying to use the seqfeature collection to pull out features in a range I was interested in.  I have two problems (maybe because I am loading features form a contig?)


In the first case, I ended up running out of space on /var/tmp.  We have about .5 GB there I am.  Code is like 

my $in1  = Bio::SeqIO->new('-file' => $contig.'.gb' , '-format' => 'Genbank');

while (my $seq = $in1->next_seq) {

            my @feat_ary = $seq->get_SeqFeatures();

            my $col = new Bio::SeqFeature::Collection();

            # add these features to the object

            my $totaladded = $col->add_features(\@feat_ary);



I end up filling /var/tmp to 100%, as I said.  


So I tried to initialize the collection like

my $col = new Bio::SeqFeature::Collection(-features => \@feat_ary);


but that gave an error:


"Can't call method "put" on an undefined value at /usr/local/biotools/perl/5.8.2/lib/site_perl/5.8.2/Bio/SeqFeature/Collection.pm line 225, <GEN0> line 95373."


That looked like the _btree wasn't set, but not sure.


I am told we have plenty of room in /tmp, so I should change my tmp dir, but the docs said that it was all in memory by default, is that not the case?  I tried to export a new tmp dir, but that didn't fix the problem...






More information about the Bioperl-l mailing list