[Bioperl-l] (no subject)

Stefan Kirov skirov at utk.edu
Thu May 27 14:40:21 EDT 2004

It is accession_number, not accession_no. Not your fault - the HOWTO has 
an typo error, probably a cut/paste problem.... Go to 
http://doc.bioperl.org/releases/bioperl-1.4/ and take a look at SeqI 
object, all methods are there...
I don't know about the structure objects...
III- supply the error msgs- this will help people help you.

Marco Landwehr wrote:

>I am new to the list. And even more new to programming. I worked through a
>basis Perl learning book and thougt now I coul go for using bioperl. But it 
> is quite harder than I thought. Because there are countless small error
>messages that drive me crazy. ;-) I do not now if this is the right place
>for questions, but I will give it a try. Right now I try to understand the
>very basics of Bio::SeqIO. I am running bioperl under Windows. (Have also an
>installation under cygwin). 
>I) I just have problems with the very first working example from the
>http://bioperl.org/HOWTOs/html/SeqIO.html . I downloaded a sample fasta file
>and while running the script: "test.pl testinput.txt fasta" I am getting the
>following error: 
>Can't locate object method "accession_no" via package "Bio::Seq" at test.pl
>line 38, <GEN0> line 1.
>This message is independant of the format (tried different ones) and the
>II) next problems while using the Bio::Structure::IO
>#!/usr/bin/perl -w
>use Bio::Structure::IO;
>$structio = Bio::Structure::IO->new(-file => "1cam.pdb", 
>    				      -format => 'PDB');
>$struc = $structio->next_structure; # returns an Entry object
>$pseq = $struc->seqres;             # returns a PrimarySeq object, thus
>$partial_sequence=$pseq->subseq(1,20); # returns a sequence string
>print "Sequence from 1 to 20 is: $partial_sequence\n";
>This is my output:
>Sequence from 1 to 20 is: XSHHWGYGKHNGPEHWHKDF
>        (in cleanup) Can't call method "CLEAR" on an undefined value at
>F:/Perl/site/lib/Bio/Structure/Entry.pm line 776, <GEN0> line 2431 during
>global destruction.
>I am wondering about the second position "S", this resisue is not defined in
>the crystal structure. What does the error message mean? And how to get rid
>of it?
>III) How to get the atoms at a certain residue? Just adding these two lines:
>@atoms = $struc->get_atoms(20);   # Atom objects, given a Residue
>print "Atoms at residue 20 are: @atoms\n";
>give me a bunch of error messages....
>Thanks for comment and/or help
>Bioperl-l mailing list
>Bioperl-l at portal.open-bio.org

Stefan Kirov, Ph.D.
University of Tennessee/Oak Ridge National Laboratory
1060 Commerce Park, Oak Ridge
TN 37830-8026
tel +865 576 5120
fax +865 241 1965
e-mail: skirov at utk.edu
sao at ornl.gov

More information about the Bioperl-l mailing list