[Bioperl-l] Problems installing GD

Dave Howorth dhoworth at mrc-lmb.cam.ac.uk
Fri Nov 5 12:18:52 EST 2004

I think you have version problems in the underlying headers and 
libraries. Check carefully that all the packages are correctly installed 
and consistent. synaptic is quite good for that.

Barry Moore wrote:
> I'm installing on an Intel box running Debian GNU/Linux 2.4

Do you mean the kernel is a 2.4 kernel?
What release of Debian are you running? woody/stable, sarge/testing, sid?

> libgd version 2.0.33

Where did you get this from? It doesn't appear to be a standard Debian 
package. I believe you need a libgd2 package, not libgd, and the 
versions for that are here:
which don't match what you have.

I use woody and ended up patching it all by hand outside of apt. A real 

Cheers, Dave

More information about the Bioperl-l mailing list