[Bioperl-l] basic problems with bioperl-db/biosql

Mikko Arvas Mikko.Arvas at postgrad.manchester.ac.uk
Thu Oct 14 11:08:28 EDT 2004


I am trying to get started using bioperl-db, but I am failing miserably.
I got bioperl 1.4 and the latest bioperl-db and biosql tarballs from CVS on
SuSe 8.1.

Installation gave one error:
t/simpleseq.....ok 6/59gzip: t/data/Titin.fasta.gz: No such file or
Can't call method "namespace" on an undefined value at t/simpleseq.t line

I tried:
> perl load_seqdatabase.pl  --dbname biosql --format fasta  test.fasta
Loading test.fasta ...

-------------------- WARNING ---------------------
MSG: insert in Bio::DB::BioSQL::SeqAdaptor (driver) failed, values were
predicted protein (1437 - 1101)","0","") FKs (9,<NULL>)
Duplicate entry 'unknown-9-0' for key 2
Could not store unknown:
------------- EXCEPTION  -------------
MSG: You're trying to lie about the length: is 56 but you say 1161

It reads always just one sequence to bioentry/biosequence tables in
regardless of the number in file and there are no duplicates in the file.

I tried:

#!/usr/bin/perl -w
use strict;
use warnings;
use Bio::DB::BioDB;
use Bio::SeqIO;
my  $db = Bio::DB::BioDB->new(
        -database => 'biosql',
        -user   => 'root',
        -dbname => 'biosql',
        -host   => 'localhost',
        -driver => 'mysql');
my $in = Bio::SeqIO->new(-format => 'fasta',
			-file => 'just_one_seq.fasta');
my $seq = $in->next_seq();
my $pseq = $db->create_persistent($seq);

No error messages, but nothing goes into the database. Basic DBI
connections outside bioperl work, the OBDA howto example of getting
sequences from EMBL works, but I can't figure out a way to get the single
sequence put to biosql by load_seqdatabase.pl out of there by

Is my script wrong, is my installion wrong, why load_seqdatabase.pl fails?

Please help,

More information about the Bioperl-l mailing list