[Bioperl-l] Bio::DB::GenPept - get_Seq_by_id

Jamie Sherman jjmail at mac.com
Fri Apr 15 20:24:18 EDT 2005

I'm getting really odd behavior when I user get_Seq_by_id to retrieve 
from GenPept. I'm trying to retrieve by name where name is like 
'ROA1_HUMAN". When I have a name that starts with a Letter it works 
great but for names that start with a number it returns junk. Is there 
a work around for this or am I doing something wrong? Can I create a 
Bio::DB::GenPept->new( arg to specify search type )?

#!/usr/bin/perl -w

use Bio::DB::GenPept;
$sp = Bio::DB::GenPept->new;

# worked $query = 'AAP1_YEAST';
# worked $query = "ROA1_HUMAN";
$query = "2AAA_YEAST";  #doesn't work?

$seq = $sp->get_Seq_by_id($query);
print $seq->desc . "\n";
print $seq->primary_id . "\n";

Alanine/arginine aminopeptidase.

Heterogeneous nuclear ribonucleoprotein A1 (Helix-destabilizing 
protein) (Single-strand binding protein) (hnRNP core protein A1).

B.taurus DNA sequence 1 from patent application EP0238993.

It is using 2 as the ID number, How do I escape this? 

More information about the Bioperl-l mailing list