[Bioperl-l] Trouble with Bio::Graphics

michael watson (IAH-C) michael.watson at bbsrc.ac.uk
Thu Aug 18 12:03:02 EDT 2005


This is going to sound like a rather hard bug to track down but maybe
someone can shed some light...

I have a rather complicated script that takes a sequence, aligns it with
other sequences, does some blast searching, then creates a whole load of
features of the result for drawing with Bio::Graphics.

I've used the script to create images of 2498 images.... But two fail...
Both with the same error message, and this is it in it's entirety (there
is no stack trace):

Can't locate object method "primary _tag" via package
"Bio::Location::Simple" at Bio/Graphics/processed_transcript.pm line 13,
<GEN12> line 56.

But of course it can't find that object method, and nor should it be...
"processed_transcript" is my glyph of choice and as I said it has worked
for 2498 of these jobs... But for some reason, on 2 of them, it's trying
to find method primary_tag not on a feature object but on a location

I am bemused.

Any help appreciated.


More information about the Bioperl-l mailing list