[Bioperl-l] TypedSeqFeatureI is in; tests which fail

Hilmar Lapp hlapp at gmx.net
Thu Aug 25 12:49:37 EDT 2005

On Aug 25, 2005, at 9:34 AM, Ewan Birney wrote:

> Jason Stajich wrote:
>> They all pass for me on OSX, and linux.  What version of perl?
> [Ewan-Birneys-Computer:wise2/src/network] birney% perl -v
> This is perl, v5.6.0 built for darwin
> Copyright 1987-2000, Larry Wall

I do suggest you upgrade perl. I know 5.6.0 is the one that comes with 
Jaguar, but it has bugs in some features bioperl is taking advantage of 
(nested regex in FTLocationFactory being just one example). I've had so 
much trouble to get Bioperl pass all tests with errors nobody else was 
getting that I finally gave up and upgraded (to Panther actually, but 
upgrading perl supposedly suffices). Once I did that most failures went 
away (and some new ones came up but that's another story and they are 
fixed meanwhile).

I brought this up a while ago in spring and I can dig up the list 
thread if you're interested. The conclusion was that essentially we'll 
have to require perl 5.6.1 with the next release.

Hilmar Lapp                            email: lapp at gnf.org
GNF, San Diego, Ca. 92121              phone: +1-858-812-1757

More information about the Bioperl-l mailing list