[Bioperl-l] Bio::OntologyIO choking on current GO

Scott Cain cain at cshl.org
Mon Feb 7 23:31:37 EST 2005


It appears that Bio::OntologyIO is choking on the component.ontology
file in GO cvs.  I ran this simple script:

#!/usr/bin/perl -w
use strict;

use Bio::OntologyIO;

my $parser = Bio::OntologyIO->new(-format => "go",
                                  -file=> 'component.ontology');

while(my $ont = $parser->next_ontology()) {
      print "read ontology ",$ont->name()," with ",
            scalar($ont->get_root_terms)," root terms, and ",
            scalar($ont->get_leaf_terms)," leaf terms\n";

when I run this through the debugger, it chokes inside of Graph.pm:

708:        my ($v, $i, $vi, $e, $o) = @_;

This is Graph version 0.55.  This script executes as expected with
sofa.ontology.  I've never looked at the OntologyIO code, so I'm hoping
someone will have a simple explanation and/or fix.


Scott Cain, Ph. D.                                         cain at cshl.org
GMOD Coordinator (http://www.gmod.org/)                     216-392-3087
Cold Spring Harbor Laboratory

More information about the Bioperl-l mailing list