[Bioperl-l] getting t_coffee to run with bioperl in linux first time

Micheleen Harris micheleen at mail.utexas.edu
Fri Jun 3 02:03:19 EDT 2005

I just installed t_coffee into my home directory on a linux machine and it 
is working fine.  Bioperl is also functioning as I tried querying genbank 
for sequence data successfully.

I then followed the following instructions to make a wrapper for t_coffee:

1. Make sure the t_coffee executable is in your path so that
     which t_coffee
     returns a t_cofee executable on your system.

  2. Define an environmental variable TCOFFEEDIR which is a dir
     which contains the 't_coffee' app:
     In bash
     In csh/tcsh
     setenv TCOFFEEDIR 

  3. Include a definition of an environmental variable TCOFFEEDIR in
     every script that will use this TCoffee wrapper module.
'/home/username/progs/T-COFFEE_distribution_Version_1.37/bin' }
     use Bio::Tools::Run::Alignment::TCoffee;

I placed the path to t_coffee and defined TCOFFEEDIR in my .bash_profile 
file as follows:

# .bash_profile

# Get the aliases and functions
if [ -f ~/.bashrc ]; then
         . ~/.bashrc

# User specific environment and startup programs


export PATH
export TCOFFEEDIR = 

I ran the following script:

#!/bin/perl -w

.37/bin' };
use Bio::Tools::Run::Alignment::TCoffee;
use Bio::Seq;
use Bio::DB::GenBank;

$coffeefound = Bio::Tools::Run::Alignment::TCoffee->exists_tcoffee();

And get the error:

Can't locate Bio/Tools/Run/Alignment/TCoffee.pm in @INC (@INC contains: 
/etc/perl /usr/lib/perl5/site_perl/5.8.5/i686-linux 
/usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.2 
/usr/lib/perl5/site_perl/5.8.2/i686-linux /usr/lib/perl5/site_perl/5.8.4 
/usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.5/i686-linux 
/usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl/5.8.4 
/usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.5/i686-linux 
/usr/lib/perl5/5.8.5 /usr/local/lib/site_perl 
/usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.2/i686-linux 
/usr/lib/perl5/site_perl/5.8.4 .) at my_scripts/find_pol.pl line 4.
BEGIN failed--compilation aborted at my_scripts/find_pol.pl line 4.

Please advise!  I'm certain I have the paths correct.  Is this a simple 
fix, did I miss something obvious?


More information about the Bioperl-l mailing list