[Bioperl-l] A question about rpsblast

=?Big5?B?tqep+qXNrOy0v7S6wkU=?= s19109014 at ym.edu.tw
Thu Oct 13 05:09:54 EDT 2005

Dear sir,

Sorry for this unexpectd mail.

Recently, I have tried to set up a web page in PHP for calling
*rpsblast* program to searchconserved domains of proteins.
When I tried to used the *php* *system* function
"system("/xxx/blast-2.2.12/bin/rpsblast -d /xxx/cdd/CDD/Cdd -i
$uploadfile -e 0.001-o /xxx/$filename.rpsout");", the command doesn't
work. I even tried to use PHP's system to call a perl script that does
the rpsblast search, but still no output. However, using the same
method, I am able to get BLAST programs using *blastall* to work.
What canI doto make rpsblast to work in a web service environment? Is
this a rpsblast bug oris there another way to solve this problem to get
the rpsblast output file?
Thanks for your time and look forward your reply.
PS: I have sent this problem to NCBI (blast-help at ncbi.nlm.nih.gov), but
they have not replyed yet. <mailto:blast-help at ncbi.nlm.nih.gov>
Ching-Hung Tzeng
Undergraduate student,
Department of Life Sciences, National Yang-Ming University.

More information about the Bioperl-l mailing list