[Bioperl-l] A question about rpsblast

Zhang Chen zhangchn2004 at gmail.com
Fri Oct 14 04:07:03 EDT 2005

Firstly, are you sure your php script have the permission to run the script?Are you sure your php/apache process have the correct uid/pid to write theblast output?Maybe you need to change some of the permission of the outputdirectory(perhaps /tmp/)?or you can try to setuid the script? 2005/10/13, ê–Ã÷Éú¿ÆÔø¾°ø™ <s19109014 at ym.edu.tw>:>> Dear sir,>> Sorry for this unexpectd mail.>> Recently, I have tried to set up a web page in PHP for calling> *rpsblast* program to searchconserved domains of proteins.> When I tried to used the *php* *system* function> "system("/xxx/blast-2.2.12/bin/rpsblast -d /xxx/cdd/CDD/Cdd -i> $uploadfile -e 0.001-o /xxx/$filename.rpsout");", the command doesn't> work. I even tried to use PHP's system to call a perl script that does> the rpsblast search, but still no output. However, using the same> method, I am able to get BLAST programs using *blastall* to work.> What canI doto make rpsblast to work in a web service environment? Is> this a rpsblast bug oris there another way to solve this problem to get> the rpsblast output file?> Thanks for your time and look forward your reply.> PS: I have sent this problem to NCBI (blast-help at ncbi.nlm.nih.gov), but> they have not replyed yet. <mailto:blast-help at ncbi.nlm.nih.gov>> Ching-Hung Tzeng> Undergraduate student,> Department of Life Sciences, National Yang-Ming University.> _______________________________________________> Bioperl-l mailing list> Bioperl-l at portal.open-bio.org> http://portal.open-bio.org/mailman/listinfo/bioperl-l>

More information about the Bioperl-l mailing list