[Bioperl-l] noob Bio::DB::Biblio problem

Chihiro Yamada cy200 at gen.cam.ac.uk
Mon Oct 31 09:19:26 EST 2005

Hiya folks,

I'm trying to use the Bio::DB::Biblio::biofetch module to get references
by ID, but I'm having a problem...

If I run this code...

use Bio::Biblio;
my $biblio = new Bio::Biblio (-access => 'biofetch');
my $ref = $biblio->get_by_id('15519282');

I get the error message:

------------- EXCEPTION  -------------
MSG: retrieval type pipeline unsupported

Bio::DB::Biblio::biofetch::get_seq_stream /opt/csw/share/perl/site_perl/Bio/DB/Biblio/biofetch.pm:237
Bio::DB::DBFetch::get_Stream_by_id /opt/csw/share/perl/site_perl/Bio/DB/DBFetch.pm:194
Bio::DB::Biblio::biofetch::get_by_id /opt/csw/share/perl/site_perl/Bio/DB/Biblio/biofetch.pm:153
STACK toplevel bbt4.pl:7


I've tried this on 1.3 (on Solaris) and 1.5.1 (using OS X) and get the
same error message.

Can anyone tell me what I'm doing wrong?




Chihiro Yamada.
FlyBase (Cambridge),            http://www.FlyBase.org/
Department of Genetics,
University of Cambridge,        email: c.yamada at gen.cam.ac.uk
Downing Street,                 Tel : 01223-333963
Cambridge,  CB2 3EH,            FAX : 01223-333992
United Kingdom.                 Memes don't exist. Spread the Word.

More information about the Bioperl-l mailing list