[Bioperl-l] Issue with Bio::SearchIO::psl (was: Bioperl bug 1977)

Chris Fields cjfields at uiuc.edu
Sat Apr 1 01:54:45 EST 2006


Albert,

I had no problems with this on Mac OS X (I'm running from 10.4.5,  
perl 5.8.6).  I noticed that several fixes were made in the last 6  
months that would potentially fix this issue, including two which  
involve newlines (that is what seems to be hanging things up here).   
Have you tried a full bioperl-live install to see if that fixes it?

computer:~/searchio_test cjfields$ perl psl.pl
/usr/local/blat/db/hg17/hg17.2bit:chr5
     100.00
/usr/local/blat/db/hg17/hg17.2bit:chr21
     90.00
/usr/local/blat/db/hg17/hg17.2bit:chr5
     85.00
/usr/local/blat/db/hg17/hg17.2bit:chr13
     80.00
/usr/local/blat/db/hg17/hg17.2bit:chr7
     80.00


Chris

On Mar 31, 2006, at 7:40 AM, Chris Fields wrote:

> I'll try it with Mac OS X this weekend to confirm; I'm running v.
> 10.4.5 with perl 5.8.6.
>
> I noticed that there's no tests for psl in SearchIO.t which should
> have caught this error.  I'll double check that in case I'm
> mistaken.  If not, I'll add a few to see what happens... maybe we'll
> get some responses back?
>
> I'll also forward this to the mail list to see if anybody else has
> had this issue.
>
> Chris
>
> On Mar 31, 2006, at 3:53 AM, Albert Vernon Smith wrote:
>
>> Running your same code, on the same file, I get:
>>
>> Output:
>> -------
>> /usr/local/blat/db/hg17/hg17.2bit:chr5
>>     100.00
>> /usr/local/blat/db/hg17/hg17.2bit:chr21
>>     90.00
>> /usr/local/blat/db/hg17/hg17.2bit:chr5
>>     85.00
>> /usr/local/blat/db/hg17/hg17.2bit:chr13
>>     80.00
>> /usr/local/blat/db/hg17/hg17.2bit:chr7
>>     80.00
>> Use of uninitialized value in pattern match (m//) at /Users/albert/
>> Documents/CSHL/cvswork/bioperl-live/Bio/SearchIO/psl.pm line 173,
>> <GEN1> line 10.
>> --------
>>
>> This is current CVS, and I see the problem on Mac OS X, as well as
>> on Linux.
>>
>> As it stands the code for Bio::Search::psl *should* be fine (as I
>> run it in my head :-), and the error message is kinda weird.  The
>> last line is #10, so there should be a value for the line, unless
>> things are trying to cycle back over it again for some reason.
>>
>> -albert
>>
>>
>> On 30.3.2006, at 22:10, Chris Fields wrote:
>>
>>> I'm running off bioperl-live from CVS (updated yesterday) and I get
>>> everything to work on this end (no errors) using your file,
>>> although I'm
>>> just printing names and HSP scores out, like this:
>>>
>>> --------------------------------------
>>>
>>> my $parser = Bio::SearchIO->new(-verbose    => $v,
>>>                                 -file       => 'psl.out',
>>>                                 -format     => 'psl');
>>>
>>> while (my $result = $parser->next_result) {
>>>     while (my $hit = $result->next_hit) {
>>>         print $hit->name,"\n";
>>>         while (my $hsp = $hit->next_hsp) {
>>>             print "    ",$hsp->score,"\n";
>>>         }
>>>     }
>>> }
>>>
>>> --------------------------------------
>>> Output:
>>> --------------------------------------
>>> /usr/local/blat/db/hg17/hg17.2bit:chr5
>>>     100.00
>>> /usr/local/blat/db/hg17/hg17.2bit:chr21
>>>     90.00
>>> /usr/local/blat/db/hg17/hg17.2bit:chr5
>>>     85.00
>>> /usr/local/blat/db/hg17/hg17.2bit:chr13
>>>     80.00
>>> /usr/local/blat/db/hg17/hg17.2bit:chr7
>>>     80.00
>>> --------------------------------------
>>>
>>> Is this a recent update of Bioperl?  There were several updates in
>>> CVS to
>>> Bio::SearchIO::psl for various bugfixes over the last year,
>>> including one
>>> that postdates the 1.5.1 release.  I would recommend trying the
>>> CVS version
>>> (copy it over the your old version if possible or just install
>>> bioperl-live
>>> from CVS).  If this doesn't work could you send your script?  It
>>> may be a
>>> specific method that's acting up.
>>>
>>> Christopher Fields
>>> Postdoctoral Researcher - Switzer Lab
>>> Dept. of Biochemistry
>>> University of Illinois Urbana-Champaign
>>>
>>>
>>>> -----Original Message-----
>>>> From: Albert Vernon Smith [mailto:smithav at cshl.edu]
>>>> Sent: Thursday, March 30, 2006 1:49 PM
>>>> To: Chris Fields
>>>> Subject: Re: Bioperl bug 1977
>>>>
>>>> [Message never went out before.  Was stuck in outbox.]
>>>>
>>>> I've attached an output which causes issues.  While parsing this
>>>> output gives me an issue, I'm actually doing something slightly
>>>> different.  I have a webBlat server, and am getting output via
>>>> LWP::UserAgent, and I take the psl returned from my query and pass
>>>> that in memory (with IO::String) to the parser.  When I do that, I
>>>> get a complaint which references the last line.  Still, parsing  
>>>> this
>>>> as a file should be the same thing.
>>>>
>>>> -albert
>>>
>>>
>>
>
> Christopher Fields
> Postdoctoral Researcher
> Lab of Dr. Robert Switzer
> Dept of Biochemistry
> University of Illinois Urbana-Champaign
>
>
>
> _______________________________________________
> Bioperl-l mailing list
> Bioperl-l at lists.open-bio.org
> http://lists.open-bio.org/mailman/listinfo/bioperl-l

Christopher Fields
Postdoctoral Researcher
Lab of Dr. Robert Switzer
Dept of Biochemistry
University of Illinois Urbana-Champaign





More information about the Bioperl-l mailing list