[Bioperl-l] RSS feed weirdness from the wiki

Mauricio Herrera Cuadra arareko at campus.iztacala.unam.mx
Mon Apr 24 14:21:43 EDT 2006

Seems to me like the problem is the new line character at the start of 
the XML files. The <?xml ...> tag must be in the first line, not at the 
second. Are these files auto-generated from some template which may 
contain the error?


Chris Fields wrote:
> Jason,
> I'm getting this error when trying the rss feed from the "Recent Changes"
> page on the wiki using Firefox  It looks like FireFox doesn't like
> the extra empty line before the xml declaration, which is a common problem
> apparently from checking (Googled it).  I think this may be a Firefox issue
> with RSS feeds as I don't see it on (ick) IE on Windows.  Haven't tried with
> Safari yet.
> XML Parsing Error: xml declaration not at start of external entity
> Location:
> http://www.bioperl.org/w/index.php?title=Special:Recentchanges&feed=rss
> Line Number 2, Column 1:
> <?xml version="1.0" encoding="utf-8"?>
> ^
> Christopher Fields
> Postdoctoral Researcher - Switzer Lab
> Dept. of Biochemistry
> University of Illinois Urbana-Champaign 
> _______________________________________________
> Bioperl-l mailing list
> Bioperl-l at lists.open-bio.org
> http://lists.open-bio.org/mailman/listinfo/bioperl-l

arareko at campus.iztacala.unam.mx
Laboratorio de Genética
Unidad de Morfofisiología y Función
Facultad de Estudios Superiores Iztacala, UNAM

More information about the Bioperl-l mailing list