[Bioperl-l] t/protgraph errors - was t/entrezgene, t/protgraph and t/FeatureIO

James D. White jdw at ou.edu
Mon Aug 7 17:11:47 EDT 2006


I recently updated to bioperl-live on Perl 5.8.5 under Solaris 9 and got 
the following:

 
Failed Test   Total Fail  Failed  List of Failed
------------------------------------------------
t/protgraph.t 66    24    36.36%  10-13 20-21 26 33 36-37 45 48-56
                                  59-60 65-66

I did notice during my first pass at installing it, that Makefile.PL
mentioned that I did not have the Clone module installed, so
Makefile.PL was skipping the testing of ProteinGraph.  (I think that
was the message.) I took care of another problem that I had and
installed the Clone module, then I got the error above.  This is an
error, not a warning and inhibits "make install" IIRC.

I briefly looked at t/protgraph.t, but I didn't know what it did,
and I did not need ProteinGraph, so to get around the error I renamed
t/protgraph.t so that "make test" did not try to run it.  Then "make
test" and "make install" worked correctly.

There was a note in t/protgraph.t around the area of tests 10-13
where someone else who did not understand the module made corrections
to get around the errors he was having.  I took that as a sign that
the errors were probably in either the module or the test and not
just my installation.

If protgraph.t does not give an error during "make test", then either
(1) it worked, or (2) it was skipped.  If you don't have Clone.pm
installed, then it was skipped.  The error summary at the end of the
output from "make test" does not list the test programs that were
skipped.  You need to check the full "make test" output to be sure.
There should be a "t/protgraph.t...........OK" message.



On 8/7/06 10:04 AM, "Brian Osborne" <osborne1 at optonline.net> wrote:

>Sendu,
>
>This one was discussed in bioperl-l a couple of months ago. All tests pass
>for me on Mac OS X 10.4.6, perl 5.8.6, bioperl-live. I'll take a closer look
>at the individual tests, see if I can find a pattern...
>
>Brian O.
>
>
>On 8/7/06 5:31 AM, "Sendu Bala" <bix at sendu.me.uk> wrote:
>
>  
>
>>> Failed Test   Total Fail  Failed  List of Failed
>>> ------------------------------------------------
>>> t/protgraph.t 66    23    34.85%  11 13 20-21 26 33 36-37 45 48-56
>>>                                    59-61 65-66
>>> 
>>> I don't know enough about it to know why its failing or what the answers
>>> are really supposed to be. Does it fail for other people? Has it ever
>>> worked in the past?
>>    
>>
>
>
>
>
>------------------------------
>
>  
>




More information about the Bioperl-l mailing list