[Bioperl-l] Bioperl 1.5.2 RC5 install on WinXP ActivePerl5.8.8.819

Sendu Bala bix at sendu.me.uk
Fri Dec 1 04:19:09 EST 2006


Chris Fields wrote:
>> Nathan S. Haigh wrote:
>>> More updates:
>>>
>>> After the failed install I updating Module::Build, and re-ran the 
>>> install, I get:
>>>
>>> -- snip --
>>> Creating new 'Build' script for 'bioperl' version '1.005002005'
>>> Warning: while trying to determine prerequisites for 
>>> S/SE/SENDU/bioperl-1.5.2_005-RCb.tar.gz wi th the help of 
>>> Module::Build the following error occurred: 'Failed to re-load 
>>> 'ModuleBuildBiope
>>> rl': Can't locate ModuleBuildBioperl.pm in @INC (@INC contains: 
>>> _build\lib C:\Perl\site\lib C:\
>>> Perl\lib C:\Documents and Settings\test) at (eval 105) line 1.
>>> '
>>>
>>> Falling back to META.yml for prerequisites 'YAML' not installed, 
>>> cannot parse 'C:\Perl\cpan\build\bioperl-1.5.2_005-RC\META.yml'
>>> -- snip --
>> I had that problem fleetingly and it drove me crazy because 
>> later I couldn't reproduce it. Is it reproducible on your end?
> 
> During Module::Build installation I see this:
> 
> ...
> t\metadata........ok
>         8/43 skipped: YAML_support feature is not enabled

You were pointing out the YAML issue? I think I'm less concerned with 
that (solution: install YAML) and much more concerned with why it can't 
reload ModuleBuildBioperl (claiming it isn't in @INC). The module in 
question is in the same dir as the Build script, so it should be found 
automatically.

The only thing I can think of is that CPAN doesn't manage to chdir to 
the directory. Hopefully I'll be able to reproduce this and then I can 
investigate further.


More information about the Bioperl-l mailing list