[Bioperl-l] Error with supplied lineages importing uniprot data

Chris Fields cjfields at uiuc.edu
Fri Dec 1 14:06:53 EST 2006


On Dec 1, 2006, at 11:12 AM, Sendu Bala wrote:

> pelikan at cs.pitt.edu wrote:
>> Hello all,
>>
>>  I'm running bioperl 1.5.2, bioperl-db 1.5.2 - RC005, under windows,
>> without Cygwin. The "make test"s have all completed without error.  
>> This
>> is my first time dealing with bioperl, so bear with me.
>>
>>    I've successfully loaded the most recent taxonomy information  
>> using the
>> biosql-schema scripts. After this, I attempted to load the most  
>> recent
>> release of the uniprot flat file dataset with the following command:
>>
>> load_seqdatabase.pl -drive mysql -dbname bioseqdb -dbuser root - 
>> dbpass
>> ********* -format swiss -safe c:\data\uniprot\uniprot_sprot.dat
>>
>> I am subsequently greeted by many of the following errors:
>>
>> Could not store Q7N3Q6:
>
> I extracted just Q7N3Q6 from
> ftp://ftp.expasy.org/databases/uniprot/current_release/ 
> knowledgebase/complete/uniprot_sprot.dat.gz
> and was able to load it in using load_seqdatabase.pl under linux  
> with no
> errors. If you make a file with just that sequence do you still get  
> the
> error?
>
> Is anyone else able to reproduce the problem?

Okay, just updated to get your latest CVS fixes for bioperl-live and  
it passes now for both Mac OS X and WinXP.

Christopher Fields
Postdoctoral Researcher
Lab of Dr. Robert Switzer
Dept of Biochemistry
University of Illinois Urbana-Champaign





More information about the Bioperl-l mailing list