[Bioperl-l] Build.PL changes

Chris Fields cjfields at uiuc.edu
Tue Dec 5 11:04:38 EST 2006


Sendu,

I think the Build.PL commits which force installation of XML::SAX::Expat
should be rolled back.  XML::Simple works with any XML::SAX backend, not
just XML::SAX::Expat, which hasn't been actively maintained since 2003 and
is deprecated in favor of XML::SAX::ExpatXS.  In fact, forcing
XML::SAX::Expat to install as the default XML::SAX backend currently breaks
blastxml parsing.

Note that forcing this also forces one to install the Expat library (now at
v 2), which now has some compatibility problems with XML::SAX::Expat (but
not ExpatXS).

Christopher Fields
Postdoctoral Researcher - Switzer Lab
Dept. of Biochemistry
University of Illinois Urbana-Champaign 




More information about the Bioperl-l mailing list