[Bioperl-l] Script taxonomy2tree version 1.4 crashed on 110 species

Chris Fields cjfields at uiuc.edu
Sat Dec 16 10:18:50 EST 2006


On Dec 16, 2006, at 8:47 AM, Sendu Bala wrote:

> Gabriel Valiente wrote:
>>> I don't think that can be true. Your error message contains 'Must  
>>> supply
>>> a Bio::Taxon'. Bio::Taxon only exists in 1.5.2 (or cvs live).
>>>
>>> If you uninstall the fink installation and install 1.5.2 using cpan
>>> (with root privileges by going sudo cpan) that should at least  
>>> get rid
>>> of the error messages...
>>>
>>>
>>>> The tree is not correct (I've parsed it from R to have a double
>>>> check) but don't know yet what the problem is with it.
>>>
>>> ... But if the tree is wrong anyway... Let me know what you find  
>>> out.
>>
>> I've uninstalled the fink installation and used the cvs instead,  
>> and the
>> error message is gone. However, on a larger set of 190 species, which
>> are all present in the NCBI taxonomy, the resulting tree has only 178
>> taxa. I suspect, something must be wrong with the merge_lineage  
>> method
>> in the major rewrite of the taxonomy2tree script. Can someone please
>> check this? I'm attaching the 190 species call to the script. Thanks,
>
> Ok, I'll look into it. You're also welcome to see if you can take your
> own code from your original taxonomy2tree script and see if you can
> merge/replace the appropriate Bio::Tree::TreeFunctionsI methods with
> your algorithms to get it working correctly. Indeed, does your  
> original
> version of the script work on this data set?
>
>
> Cheers,
> Sendu.

Sendu,

Don't know if it helps, but when I tried Gabriel's shell script last  
night I ran a modification of taxonomy2tree to see what would pop  
up.  Everything is fine up to about 100 iterations, then merge_lineage 
() starts dropping leaf nodes.

chris 
  


More information about the Bioperl-l mailing list