[Bioperl-l] problems installing bioperl

Sendu Bala bix at sendu.me.uk
Tue Dec 19 12:06:03 EST 2006


Scott Cain wrote:
> I really don't think the BioPerl version detection is wrong.  I actually
> don't check Bio::Root::Version::VERSION in Makefile.PL, I check
> Bio::Graphics::Panel->api_version.  When it doesn't find the correct
> api_version, it gives a warning the BioPerl 1.5.2 is not installed.  I
> have seen this happen when more than one BioPerl instance is installed
> and `perl Makefile.PL` finds the wrong one first.

Yes, I saw that, which is why I thought I must be looking at something 
different to what the OP had installed.


> My suggestion is to try reinstalling BioPerl and providing the --uninst 1 argument to remove
> older versions of BioPerl:
> 
>   sudo ./Build install --uninst 1

My confusion is that he has definitely installed 1.5.2 and this version 
is being polled for its version number (by something!) and returning the 
correct '1.0050021', whilst the something expects '1.52'. Anyway, this 
can only be resolved if Stephan provides the real error message and its 
context.


More information about the Bioperl-l mailing list