[Bioperl-l] Minimal versions requirements/warnings for SearchIO text parsing?

Chris Fields cjfields at uiuc.edu
Thu Feb 16 17:29:15 EST 2006

I'm floating this to see what people think...

I'm beginning to wonder, especially when I'm wading through the
regex/parsing nightmare in SearchIO::blast, if we should either require a
minimal BLAST version number for parsing to work in SearchIO::blast.  I
could add a '$self->throw("Requires BLAST v2.x.x")' or at least give a
warning if the blast version number is below a minimal version, so at least
people will know what the problem is (not us!).

The regexes are really piling up, and the latest changes in blastn and
tblastx will require adding a few more.  I also think that this would help
remind everybody running the latest Bioperl that there are also newer
versions of BLAST.  My current thought is to get it working for the latest
text output from NCBI, check it against the last version of BLAST (v.
2.2.12, which, luckily, blastcl3 generates), and not worry too much about
older ones.

Any thoughts on this?

Christopher Fields
Postdoctoral Researcher - Switzer Lab
Dept. of Biochemistry
University of Illinois Urbana-Champaign 

More information about the Bioperl-l mailing list