[Bioperl-l] error running load_seqdatabase.pl

Hilmar Lapp hlapp at gmx.net
Fri Jan 6 13:01:38 EST 2006

On Jan 6, 2006, at 9:20 AM, Chris Fields wrote:

> Hilmar,
> Did this ever get resolved?  I tried to reinstall a biosql database 
> using
> bioperl-db and got the same problems.  I'll list out everything I ran 
> into
> and what I pan on trying, as it's been a long time since I've tried 
> this.
> Currently, I'm using ActiveState Perl on WinXP and MySQL 
> 4.1.14.
> Using nmake and installing worked fine.  Loading the biosql schema and
> loading taxonomy info also worked fine, although I had to manually 
> untar the
> taxonomy archive so load_ncbi_taxonomy.pl could find the files (stupid
> windows).  However, this is what happens when using 
> load_seqdatabase.pl:
> C:\Perl\Scripts>load_seqdatabase.pl -dbname dihydroorotase -dbuser root
> NP_249092.gpt
> Loading NP_249092.gpt ...
> Undefined subroutine &Bio::Root::Root::debug called at
> C:/Perl/site/lib/Bio/DB/BioSQL/BasePersistenceAdaptor.pm line 1537, 
> <GEN0>
> line 65.
> If I removed all args except the sequence file, it gives the same 
> response,
> which means it happens before the connection is made to the database:

This happens indeed before a connection is made because it happens at 
the point it tries to dynamically load the BioSQL driver for the 

	$self->debug("attempting to load driver for adaptor class $class\n");

The BioSQL driver is loaded before the DBD driver is loaded.

The module in which this happens (i.e., the persistence adaptor) has 
been loaded dynamically as well.

Bio::Root::Root is in the 'use' statements, and the debug() method 
clearly exists. I'm at a loss as to why perl complains on certain 
Windows platforms. If somebody can tell me what, if anything, can be 
done to make this work on those platforms too I'll be glad to implement 

> [...]
> Here's the error messages from that first test (warning it's very 
> messy):
> C:\Perl\bin\perl.exe "-MExtUtils::Command::MM" "-e" "test_harness(0, 
> 'bl
> ib\lib', 'blib\arch')" t\01dbadaptor.t t\02species.t t\03simpleseq.t
> t\04swiss.t t\05seqfeature.t t\06comment.t t\07dblink.t t\08genbank.t
> t\09fuzzy2.t t\10ensembl.t t\11locuslink.t t\12ontology.t t\13remove.t
> t\14query.t t\15cluster.t
> t\01dbadaptor.....ok 1/19Subroutine new redefined at
> [...]
> Subroutine debug redefined at C:/Perl/site/lib/Bio\Root\Root.pm line 
> 356.

So obviously it is there, right? So why doesn't perl see it a minute 

> [...]
> I'll end with that.  At this moment, I can't see it working with the 
> current
> setup.  I was using perl 5.8 with the old setup but I upgraded mysql 
> at some
> point when working with gbrowse (I can't remember what the old version 
> was);
> I'll try upgrading to the newest ActiveState version to see what 
> happens.
> Could it be the MySQL version?

I don't think it has anything to do with the MySQL version, or the DBD 
driver for that matter. Instead, it looks like on issue with dynamic 
loading of perl modules on your particular platform.


> Christopher Fields
> Postdoctoral Researcher - Switzer Lab
> Dept. of Biochemistry
> University of Illinois Urbana-Champaign
> _______________________________________________
> Bioperl-l mailing list
> Bioperl-l at portal.open-bio.org
> http://portal.open-bio.org/mailman/listinfo/bioperl-l
Hilmar Lapp                            email: lapp at gnf.org
GNF, San Diego, Ca. 92121              phone: +1-858-812-1757

More information about the Bioperl-l mailing list