[Bioperl-l] remoteblast xml problem

Chris Fields cjfields at uiuc.edu
Fri Jun 2 10:30:18 EDT 2006


Sendu, Hubert,


Hubert, your code looks fine so Sendu's patch should fix the problem (break
out of that infinite loop).  I applied Sendu's patch to RemoteBlast in CVS;
it passed all tests in RemoteBlast.t.  Try updating from CVS to see if it
works.  

Chris

> -----Original Message-----
> From: bioperl-l-bounces at lists.open-bio.org [mailto:bioperl-l-
> bounces at lists.open-bio.org] On Behalf Of Sendu Bala
> Sent: Friday, June 02, 2006 4:04 AM
> To: bioperl-l at lists.open-bio.org
> Subject: Re: [Bioperl-l] remoteblast xml problem
> 
> Hubert Prielinger wrote:
> > hi,
> > I have the following program and it worked quite well, for retrieving
> > remoteblast results in a textfile,
> > now I have altered it to to xml, and it didn't work anymore.....
> > it takes all the parameter at the commandline, submits the query, but I
> > don't retrieve any results file anymore.....
> >
> > it seems that it hangs in a endless loop......
> > the only output I get is:  $rc is not a ref! over and over..... it
> > doesn't enter the else term anymore....
> 
> There is no problem with your code. The problem is with the NCBI server
> and should be reported to them. You can visit the site and do a blast,
> requesting xml format, and you will typically get one normal 'waiting'
> message and the promise that it will be updated in x seconds, but
> subsequent attempts to get progress information result in an xml error
> page because the NCBI server doesn't actually send any data.
> 
> Unfortunately the way that the bioperl code is written, it treats no
> data as 'waiting' instead of an error. I've offered a patch to fix this
> at this bug page:
> http://bugzilla.bioperl.org/show_bug.cgi?id=2015
> _______________________________________________
> Bioperl-l mailing list
> Bioperl-l at lists.open-bio.org
> http://lists.open-bio.org/mailman/listinfo/bioperl-l



More information about the Bioperl-l mailing list