[Bioperl-l] Test errors in bioperl-run

Jason Stajich jason at bioperl.org
Tue Jun 13 10:19:04 EDT 2006


The latest version of YN00 (3.15) doesn't work with the current code  
as the output has changed substantially as Yang is now provided  
several different method's simple Ka and Ks calculations.  Downgrade  
to PAML 3.14 or roll up your sleeves and figure out what is breaking  
-- which is the regexp in about line 363 that detects when to start  
parsing for the Pairwise data as well as the function  
parse_YN_Pairwise....

I just don't have very much time anymore to follow changes to the  
software packages so I am hopeful that other developers that use our  
software as do molecular evolutionary studies will get involved to  
help this effort.

I may have to run a few batches of analyses myself later in the week  
using PAML so I will try and fix this if I can make the time.

-jason
On Jun 12, 2006, at 4:23 PM, Ryan Golhar wrote:

> I'm trying to install the bioperl-run package and an getting errors  
> from
> make test regarding PAML:
>
> t/PAML....................ok 2/18Can't call method "get_MLmatrix"  
> on an
> undefined value at t/PAML.t line 85, <GEN2> line 85.
> t/PAML....................dubious
>         Test returned status 2 (wstat 512, 0x200)
>         after all the subtests completed successfully
>
> Is this a legitimate error or am I missing something?
>
> Ryan
>
> _______________________________________________
> Bioperl-l mailing list
> Bioperl-l at lists.open-bio.org
> http://lists.open-bio.org/mailman/listinfo/bioperl-l

--
Jason Stajich
Duke University
http://www.duke.edu/~jes12




More information about the Bioperl-l mailing list