[Bioperl-l] Installation problems...

Nathan S. Haigh n.haigh at sheffield.ac.uk
Mon Nov 13 14:50:53 EST 2006


Alessandro Botton wrote:
> Sorry to disturb you...
> I tried to install BioPerl by means of cpan. I have previously 
> installed Bundle::BioPerl and everything was ok, and then tried to 
> force the Bioperl installation. Anyway, I attach the "make test" part 
> taken from my shell during Bioperl installation and the result of the 
> second test (tut1.pl, also in attachment) suggested to detect a good 
> installation of Biopelr (the first one was ok). if you need further 
> information please ask me.
> Thank you in advance for your precious help.
> Best wishes,
> A.Botton
>

Hi Alessandro,

The Bioperl 1.4 release is now somewhat out-of-date and you might be 
better to install the latest 1.5.x developer release. We are currently 
working towards a 1.5.2 release, which should be out within the next 
week or so. The latest version is 1.5.2 release candidate 3 - it should 
be installable via CPAN.
I will refer you to what has been said about the 1.5.2 RC3 release:

"Users:

   Even though 1.5.2 is a 'developer' release, we consider it the most
   stable and capable version of Bioperl, and recommend that you use
   it in all but the most critical production environments. Please
   try it out and let us know of any problems or difficulties you run
   into."


At the moment CPAN doesn't see 1.5.x as a developer release (which 
should be fixed shortly). Therefore you should still be able to install 
it with:

prompt> perl -MCPAN -e shell
CPAN> install Bioperl

Once the 1.5.2 RC3 distribution file is fixed, the above will not work. 
Let me know how you get on and if you get 1.5.2 RC3 installed.

Cheers
Nathan


More information about the Bioperl-l mailing list