[Bioperl-l] bioperl-db question

Hilmar Lapp hlapp at gmx.net
Sat Nov 18 22:08:00 EST 2006


This is very odd. I would mean that preparing the statement failed,  
i.e., that the generated SQL was not accepted by the server (or the  
Oracle client library).

Which test does this happen with?

Could you run the test alone in which it happens with TEST_VERBOSE  
turned on? E.g.,

	$ make test_03simpleseq TEST_VERBOSE=1

if it's the simpleseq test that's causing the failure. Capture the  
output in a file and send it to me.

	-hilmar

On Nov 18, 2006, at 3:57 AM, gang wu wrote:

> Hi everyone,
>
> I used to use MySQL to host the BioSQL schema and load Genbank into it
> with the 'load_seqdatabase.pl' without problem(except extremely  
> slow. It
> took about 12 hours to load Arabidopsis thaliana). I just loaded the
> BioSQL schema in Oracle 10g. I could load NCBI Taxonomy database  
> without
> problem.
>
> When I 'make test' with bioperl-db-1.5.2.R3, all tests can pass with
> MySQL while always saw an error with Oracle:
>       Can't call method "bind_param" on an undefined value at
> /root/.cpan/build/bioperl-db-1.5.2-RC3/blib/lib/Bio/DB/BioSQL/ 
> BasePersistenceAdaptor.pm
> line 939.
>
> , where the code is $sth->bind_param();
>
> Any idea what the problem is?
>
> Gang
> _______________________________________________
> Bioperl-l mailing list
> Bioperl-l at lists.open-bio.org
> http://lists.open-bio.org/mailman/listinfo/bioperl-l

-- 
===========================================================
: Hilmar Lapp  -:-  Durham, NC  -:-  hlapp at gmx dot net :
===========================================================







More information about the Bioperl-l mailing list