[Bioperl-l] bioperl-db question

Chris Fields cjfields at uiuc.edu
Mon Nov 20 12:52:12 EST 2006


> Hi Hilmar,
> 
> Thanks for your message. Below are several tests for Oracle 
> and MySQL. 
> MySQL actually also has two tests with failed items which may 
> be related to data in BioSQL database.
> 
> Could it be my Oracle installation/configuration has some issues?
> 
> Thanks.
> 
> Gang

...

You stated in a previous post that you had preloaded taxonomy; the various
species test fails may be from that.  Hilmar pointed out in a previous
thread that tests require a BioSQL database without NCBI taxonomy loaded
(i.e. just the schema).  The INSTALL doc should now state that.

As for the rest, could it be the DBharness.biosql.conf file setup, which
assumes MySQL by default?  If you switch to Oracle you have to indicate the
proper DBD driver in the conf file:

...

    # DBD driver to use - mandatory
    'driver'        => 'oracle',

...

Chris


> Hilmar Lapp wrote:
> > This is very odd. I would mean that preparing the statement failed, 
> > i.e., that the generated SQL was not accepted by the server (or the 
> > Oracle client library).
> >
> > Which test does this happen with?
> >
> > Could you run the test alone in which it happens with TEST_VERBOSE 
> > turned on? E.g.,
> >
> >     $ make test_03simpleseq TEST_VERBOSE=1
> >
> > if it's the simpleseq test that's causing the failure. Capture the 
> > output in a file and send it to me.
> >
> >     -hilmar
> >
> > On Nov 18, 2006, at 3:57 AM, gang wu wrote:
> >
> >> Hi everyone,
> >>
> >> I used to use MySQL to host the BioSQL schema and load 
> Genbank into it
> >> with the 'load_seqdatabase.pl' without problem(except 
> extremely slow. It
> >> took about 12 hours to load Arabidopsis thaliana). I just 
> loaded the
> >> BioSQL schema in Oracle 10g. I could load NCBI Taxonomy 
> database without
> >> problem.
> >>
> >> When I 'make test' with bioperl-db-1.5.2.R3, all tests can 
> pass with
> >> MySQL while always saw an error with Oracle:
> >>       Can't call method "bind_param" on an undefined value at
> >> 
> /root/.cpan/build/bioperl-db-1.5.2-RC3/blib/lib/Bio/DB/BioSQL/
BasePersistenceAdaptor.pm 
> >>
> >> line 939.
> >>
> >> , where the code is $sth->bind_param();
> >>
> >> Any idea what the problem is?
> >>
> >> Gang
> >> _______________________________________________
> >> Bioperl-l mailing list
> >> Bioperl-l at lists.open-bio.org
> >> http://lists.open-bio.org/mailman/listinfo/bioperl-l
> >
> > --===========================================================
> > : Hilmar Lapp  -:-  Durham, NC  -:-  hlapp at gmx dot net :
> > ===========================================================
> >
> >
> >
> >
> >
> 
> _______________________________________________
> Bioperl-l mailing list
> Bioperl-l at lists.open-bio.org
> http://lists.open-bio.org/mailman/listinfo/bioperl-l



More information about the Bioperl-l mailing list