[Bioperl-l] Bioperl 1.4 on Windows

Chris Fields cjfields at uiuc.edu
Mon Nov 20 18:33:48 EST 2006


On Nov 20, 2006, at 4:49 PM, Nathan S. Haigh wrote:

> There have been at least a coupl eof posts recently about users having
> problems installing bioperl 1.4 using the PPM GUI shipped with
> ActivePerl 5.8.8.819. I think this is because the Bioperl 1.4 ppd is
> built for PPM3 and not PPM4. Would it make sense to update the Bioperl
> 1.4 PPD since it is the official "stable" release?
>
> Nath

We could change the PPD to remove any versioning requirements.  It's  
possible that PPM4 treats them as explicit version requirements, so  
instead of installing rel. X or greater, it only tries to install  
rel. X, which then has version requirements of it's own that PPM4  
misreads.  Not sure if this is a common problem with PPM4 but it's  
definitely bad.

The best course of action for Windows users will be to update to  
1.5.2 when the final version is released.  The vast majority will be  
using it for parsing BLAST reports and retrieving sequences, both of  
which have undergone major revisions since 1.4 (in fact, I don't  
think BLAST report parsing will work if they run a BLAST version  
before 2.2.13).

Christopher Fields
Postdoctoral Researcher
Lab of Dr. Robert Switzer
Dept of Biochemistry
University of Illinois Urbana-Champaign





More information about the Bioperl-l mailing list