[Bioperl-l] Bioperl 1.5.2 RC5 install on WinXP ActivePerl5.8.8.819

Chris Fields cjfields at uiuc.edu
Thu Nov 30 14:19:34 EST 2006


> Nathan S. Haigh wrote:
> > More updates:
> > 
> > After the failed install I updating Module::Build, and re-ran the 
> > install, I get:
> > 
> > -- snip --
> > Creating new 'Build' script for 'bioperl' version '1.005002005'
> > Warning: while trying to determine prerequisites for 
> > S/SE/SENDU/bioperl-1.5.2_005-RCb.tar.gz wi th the help of 
> > Module::Build the following error occurred: 'Failed to re-load 
> > 'ModuleBuildBiope
> > rl': Can't locate ModuleBuildBioperl.pm in @INC (@INC contains: 
> > _build\lib C:\Perl\site\lib C:\
> > Perl\lib C:\Documents and Settings\test) at (eval 105) line 1.
> > '
> > 
> > Falling back to META.yml for prerequisites 'YAML' not installed, 
> > cannot parse 'C:\Perl\cpan\build\bioperl-1.5.2_005-RC\META.yml'
> > -- snip --
> 
> I had that problem fleetingly and it drove me crazy because 
> later I couldn't reproduce it. Is it reproducible on your end?

During Module::Build installation I see this:

...
t\metadata........ok
        8/43 skipped: YAML_support feature is not enabled
t\metadata2.......ok
        4/18 skipped: YAML_support feature is not enabled
t\moduleinfo......ok
t\notes...........ok
t\parents.........ok
t\pod_parser......ok
t\ppm.............skipped
        all skipped: C_support not enabled
t\runthrough......ok
        7/32 skipped: YAML_support feature is not enabled
t\signature.......skipped
        all skipped: $ENV{TEST_SIGNATURE} is not set
t\tilde...........ok
t\versions........ok
t\xs..............skipped
        all skipped: C_support not enabled
All tests successful, 3 tests and 27 subtests skipped.
Files=21, Tests=679, 262 wallclock secs ( 0.00 cusr +  0.00 csys =  0.00
CPU)
  C:\WINDOWS\nmake.EXE test -- OK
Running make install
...


Christopher Fields
Postdoctoral Researcher - Switzer Lab
Dept. of Biochemistry
University of Illinois Urbana-Champaign 

 



More information about the Bioperl-l mailing list