[Bioperl-l] test::more template

Sendu Bala bix at sendu.me.uk
Fri Oct 20 07:06:07 EDT 2006


Nathan Haigh wrote:
> If there are known bugs in a particular version of software, what is the
> best approach for dealing with tests that would fail due to this bug?
> Simply skip those tests that would be affected by the bug, or to fail if
> the affected version is detected and report the reason so the user is
> informed? Or simply bump the minimum version to one above the affected
> versions?
> 
> For example, t/Clustalw has a test for at least version 1.8. It then has
> some profile alignment tests that are only run if version > 1.82 is
> installed. It states that versions 1.81 and 1.82 are affected by a
> profile alignment bug - which i assume would make the tests fail.

Specific cases like this, I'd discuss on the list/ with the author of
the module in question. Maybe there is some great need to allow usage
with <1.81?

My view, based purely on what you've said above, bump the pre-requisite
to a version that works.



More information about the Bioperl-l mailing list