[Bioperl-l] Bioperl versioning

Chris Fields cjfields at uiuc.edu
Mon Oct 23 11:39:09 EDT 2006


...
> That does not present us with a way to have 1.5.2 marked as a developer
> release in CPAN.
> 
> Also, see the discussion here:
> http://perldoc.perl.org/functions/require.html
> 
> Since we require 5.6.1 the backwards-compatible issues maybe don't apply
> to us, but do these ideas work with modules, or just Perl itself? Is
> CPAN et al. happy with this form of versioning?
> 
> /Something/ needs to be done about Bioperl versioning, because the
> current 1.4 or 1.5 is completely inadequate.

I think using 'require Foo x.y.z' is applicable to modules as well.  There
is something in Programming Perl about this, just don't have it on hand...

Not sure about CPAN, so we need to look into it.

Christopher Fields
Postdoctoral Researcher - Switzer Lab
Dept. of Biochemistry
University of Illinois Urbana-Champaign



More information about the Bioperl-l mailing list