[Bioperl-l] Bioperl tests: Test, Test::Simple, Test::More?

Chris Fields cjfields at uiuc.edu
Sun Sep 3 01:02:28 EDT 2006


 From the INSTALL:

o SYSTEM REQUIREMENTS

- perl 5.005 or later*.

Frankly, I think we should change that to v 5.8; it's been out for  
over three years now.  perl 5.10 isn't too far off (let alone Perl6)  
and perl 5.005, according to CPAN, is 8 years old.

Chris


On Sep 2, 2006, at 9:32 PM, Torsten Seemann wrote:

> Chris Fields wrote:
>> Does anyone have suggestions for a test suite other than the  
>> regular ol'
>> Test.pm?  I would like something that's a bit more flexible for  
>> Bioperl but
>> won't require a ton of revisions for current tests.
>
> I notice that BioPerl still comes bundled with t/Test.pm 1.15 and  
> most of the t/*.t test scripts have a BEGIN block which loads the  
> bundled one if a local copy doesn't exist.
>
> Is this still necessary?
>
> I think Test.pm has been part of the core Perl distribution since  
> 5.6 (happy to be corrected - it's in "man perltoc" if you have 5.6  
> installed), and Test::Simple and Test::More are standard in Perl 5.8.
>
> What is the minimum Perl version required for bioperl-live?
>
> -- 
> Torsten Seemann
> Victorian Bioinformatics Consortium, Monash University, Australia

Christopher Fields
Postdoctoral Researcher
Lab of Dr. Robert Switzer
Dept of Biochemistry
University of Illinois Urbana-Champaign





More information about the Bioperl-l mailing list