[Bioperl-l] Bioperl tests: Test, Test::Simple, Test::More?

Sendu Bala bix at sendu.me.uk
Sun Sep 3 04:45:38 EDT 2006

Chris Fields wrote:
>  From the INSTALL:
> - perl 5.005 or later*.

On the wiki it says 'Bioperl currently requires at least Perl 5.6.0 but 
at least 5.8.0 is recommened [sic]'


> Frankly, I think we should change that to v 5.8; it's been out for  
> over three years now.  perl 5.10 isn't too far off (let alone Perl6)  
> and perl 5.005, according to CPAN, is 8 years old.

I'm certainly with you regarding 5.8. Full disclosure: my 
Bio::PullParserI requires 5.8 for certain things. I was going to add 
some <5.8 detection and work-around code, but it would be much better if 
we could just bump the requirement to 5.8.

More information about the Bioperl-l mailing list