[Bioperl-l] min. perl ver. for next release, was Bioperl tests

Chris Fields cjfields at uiuc.edu
Sun Sep 3 10:31:37 EDT 2006


On Sep 3, 2006, at 3:45 AM, Sendu Bala wrote:

> Chris Fields wrote:
>>  From the INSTALL:
>>
>> o SYSTEM REQUIREMENTS
>>
>> - perl 5.005 or later*.
>
> On the wiki it says 'Bioperl currently requires at least Perl 5.6.0  
> but
> at least 5.8.0 is recommened [sic]'
>
> http://www.bioperl.org/wiki/Installing_BioPerl
>
>
>> Frankly, I think we should change that to v 5.8; it's been out for
>> over three years now.  perl 5.10 isn't too far off (let alone Perl6)
>> and perl 5.005, according to CPAN, is 8 years old.
>
> I'm certainly with you regarding 5.8. Full disclosure: my
> Bio::PullParserI requires 5.8 for certain things. I was going to add
> some <5.8 detection and work-around code, but it would be much  
> better if
> we could just bump the requirement to 5.8.

Agreed.  We should probably get some input from Brian, Hilmar, etc.   
As Torsten and I have pointed out, Test and Test::More are included  
in 5.8 so there's no need to include it in the distribution.

perl v. 5.8 has been out since late 2002, so I think it's feasible.

Christopher Fields
Postdoctoral Researcher
Lab of Dr. Robert Switzer
Dept of Biochemistry
University of Illinois Urbana-Champaign





More information about the Bioperl-l mailing list