[Bioperl-l] Bioperl tests: Test, Test::Simple, Test::More?

Bernhard Schmalhofer Bernhard.Schmalhofer at biomax.com
Tue Sep 5 06:12:29 EDT 2006


Torsten Seemann wrote:
>  >> Frankly, I think we should change that to v 5.8; it's been out for
>  >> over three years now.  perl 5.10 isn't too far off (let alone Perl6)
>  >> and perl 5.005, according to CPAN, is 8 years old.

I remember that a while back the same kind of discussion took place on 
the Parrot mailing list, http://www.parrotcode.org.
The result was to require 5.6.1 or later, as perl 5.6.0 wasn't very stable.

With 5.6.1 required, some cleanup could be done, e.g.
- Replace 'use vars qw( $dummy );' with 'our $dummy;'
- Get rid of IO::Scalar.


Just my $0.02,

   Bernhard Schmalhofer

-- 
**************************************************
Dipl.-Physiker Bernhard Schmalhofer
Senior Developer
Biomax Informatics AG
Lochhamer Str. 11
82152 Martinsried, Germany
Tel: +49 89 895574-839
Fax: +49 89 895574-825
eMail: Bernhard.Schmalhofer at biomax.com
Website: www.biomax.com
**************************************************


More information about the Bioperl-l mailing list