[Bioperl-l] min. perl ver. for next release, was Bioperl tests

Chris Fields cjfields at uiuc.edu
Tue Sep 5 14:31:10 EDT 2006


...
> But there may also be lots of people who just never had any reason to
> upgrade.

There are plenty of reasons to upgrade, just check Torsten's post for v. 5.6
and v.5.8.  And, like I mentioned before, v. 5.10 is not far off either.
The wiki states that v5.6 is required; based on Bernhard's and Lincoln's
comments I think we should stick with a minimum of v. 5.6.1 for now in the
next release.

> Even if no module in Bioperl required the latest Perl to function, to
> what extent do we support people on older Perls anyway?
> 
> How can we claim the latest version of Bioperl is compatible with 5.005
> (or whatever), when few (none?) of the developers test the code fully on
> earlier versions of Perl? How do we properly support something we don't
> use?
>
> Anyway, support for older version of Perl shouldn't be dropped 'just
> because', but perhaps only when something critical can no longer be done
> at all under old Perls.

I don't think we would drop support 'just because.'  If anything, we want
the ability to use the many advantages that v. 5.8 offers.  As for extra
modules (like my Test::More) we could add those to Bundle::BioPerl as a
prereq.  Test::More supposedly works for 5.0045 and up.

Requiring that we continually support a version of perl that is eight years
old and is no longer actively maintained (v5.005, which is what the INSTALL
docs state) doesn't make much sense.  In my opinion, we effectively hobble
ourselves by not allowing the developers to utilize advantages in newer
versions of perl.

> For those that dislike all the backward-compatibility cruft necessary,
> one would suppose that the version of Bioperl released for Perl 6 would
> be a fresh, clean start.

Yes, but then, using the same logic, we would run into the same problems
down the road with Perl6.8.  At some point we have to address how long we
can support older versions of perl.  Three years past the perl release?
Ten?  'Indefinitely' is not really the best answer.

We could use a rough 'support window', where we could stop actively
supporting perl versions five years older than the bioperl version, using
v5.6.1 here as an example.  We could also recommend (push?) v5.8.  Here, by
'active support' I mean if certain modules don't work b/c the perl version
is too old (5.005 or less), we will not modify code to support it.  At the
very least, it will not be our top priority.
 
Chris



More information about the Bioperl-l mailing list