[Bioperl-l] Bioperl 1.5.2 Prerequisites

Nathan S. Haigh n.haigh at sheffield.ac.uk
Tue Sep 19 17:11:34 EDT 2006


Yesterday, I started having a look at installing the latest code on the
1.5.2 branch with the aim of running all the tests with Perl 5.6.1.

However, I ran into a few hurdles including some regarding dependencies.

Firstly, in order to run large test suites that break the command line
length limit in windows (and possibly other OS's at different limits)
ExtUtils::MakeMaker >= 6.06 is required. It may not be necessary for
*nix but it is required if installing Bundle::BioPerl via CPAN and
probably also Bioperl (however, I haven't got that far yet - this is
tomorrows job), but it is required for testing under windows. It could
be added as a prerequisite in a ppd, but most people installing it this
way probably wouldn't run the test suite. How should this be dealt with?

For prerequisites where there isn't a ppd available in either the 3 main
repositories used for Windows install via PPM, how should these be dealt
with? I could make the ppd's but should they go into Bundle::BioPerl? or
just pop them in the Bioperl repository?

What modules should go into Bundle::BioPerl? My feeling is that all
non-essential modules should go into Bundle::BioPerl so that it's
install with Bioperl would yield a fully functional Bioperl that is
capable of running all the tests. This way, either 1) the Bioperl ppd
could contain the minimal set of prerequisites and the user can
optionally install Bundle::BioPerl or 2) the Bioperl ppd could contain
Bundle::BioPerl as a prerequisite in order that PPM users would get a
fully functional Bioperl from the off - which might be beneficial to
more naive users/beginners.

Anyway, I'll get back to the testing tomorrow.
Nath





More information about the Bioperl-l mailing list