[Bioperl-l] New Bioperl minimum Perl version -- 5.6.1 or 5.8 ?

Hilmar Lapp hlapp at gmx.net
Sat Sep 23 23:48:49 EDT 2006


They may well be. I'd recommend against requiring a version that you  
don't have to require. Much (most) of Bioperl will run just fine in  
5.6.1. Modules that need Perl 5.8.x and higher should check that (via  
'use' at compile or 'require' at runtime), and it is easy enough to  
test for the version of perl and exit gracefully in a test script if  
the perl version falls short.

	-hilmar

On Sep 23, 2006, at 9:09 PM, Torsten Seemann wrote:

>
>  From a previous thread it was unclear whether it had been decided  
> to move the
> minimum Perl version for Bioperl to 5.6.1 or 5.8 ?
>
> http://news.gmane.org/find-root.php? 
> group=gmane.comp.lang.perl.bio.general&article=12304
>
> The "INSTALL" file says 5.005, the wiki says "5.6, prefer 5.8",  
> recent MAC OS X
> users only have 5.6, a lot of modules already need 5.6 anyway, and  
> Sendu says
> his new pull-parsers need 5.8.
>
> My impression was that it was informally decided to require 5.6.1,  
> but there
> appears to be a good case to move to 5.8 (now 3 years old).  
> Obviously there are
> still people who are unable to migrate to Perl 5.8 yet, but are  
> they the same
> users who will be using the latest Bioperl version anyway?
>
> -- 
> Torsten Seemann
> Victorian Bioinformatics Consortium, Monash University, Australia
> _______________________________________________
> Bioperl-l mailing list
> Bioperl-l at lists.open-bio.org
> http://lists.open-bio.org/mailman/listinfo/bioperl-l
>

-- 
===========================================================
: Hilmar Lapp  -:-  Durham, NC  -:-  hlapp at gmx dot net :
===========================================================







More information about the Bioperl-l mailing list