[Bioperl-l] Package status for 1.5.2

Brian Osborne osborne1 at optonline.net
Mon Sep 25 15:47:54 EDT 2006


Hilmar,

Ah!

use Graph 0.80;

works but

use Graph .80;

does not. That is odd, quite unperly.


Brian O.




On 9/25/06 11:45 AM, "Hilmar Lapp" <hlapp at gmx.net> wrote:

> Odd. Does anyone know the answer to this conundrum? -hilmar
> 
> On Sep 25, 2006, at 10:09 AM, Brian Osborne wrote:
> 
>> Hilmar,
>> 
>> Yes I have but I'm puzzled since it doesn't seem to make a difference.
>> Example, I put this into the key module Bio::Network::ProteinNet:
>> 
>> use Graph .90;
>> 
>> Now there is no version .90, the latest is .80. I've even run 'make
>> install'
>> to assure that all versions of this module on my machine bear this
>> statement
>> yet still all the tests run fine. Same thing with the test code, it
>> doesn't
>> seem to matter what version I require, existing or non-existent.
>> How is this
>> supposed to work?
>> 
>> And it's not that Graph.pm doesn't state the version:
>> 
>> ~/bioperl-network>grep -i version /Library/Perl/5.8.6/Graph.pm
>> use vars qw($VERSION);
>> $VERSION = '0.80';
>> 
>> 
>> Brian O.
>> 
>> 
>> 
>> On 9/25/06 8:25 AM, "Hilmar Lapp" <hlapp at gmx.net> wrote:
>> 
>>> BTW if you have a minimum version requirement that should go into the
>>> module 'use' as well, not just the test script. Maybe you had done
>>> that anyway already?
>> 
>> 




More information about the Bioperl-l mailing list